Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
D3 Zoom verschiedene Versionen
#1
Hallo,

ich habe heute D3 kennen gelernt, denn ich muss bei einer Grafik zoomen können. Finde lauter Beispiele im Netz, sogar für verschiedene D3 Versionen. Je neuer desto "einfacher" soll es werden und ein Beispiel funktioniert nur mit V7, davor entweder nicht oder zeigt nicht mal ein Bild an. Man kann aber auch mit V3 und 4 schon zoomen.

Das Programm das ich vorgefunden habe ist auf V5 geschrieben. Soll ich also den Zoom so schreiben dass er für V5 funktioniert oder insgesamt auf V7 updaten? Könnte sein dass dann andere Funktionen nicht mehr funktionieren oder ist das abwärtskompatibel?
Zitieren
#2
Das ist ein Thema, wo ich gar nicht helfen kann.
Bei solchen Plugins ist, das immer eine gute Frage was man macht.

Zb bei jQuery.
Vor 3 Jahren oder so hatte jQuery Funktionen, die es in der aktuellen Version nicht mehr gibt.
Deswegen hat man auch öfters Anfragen in den Foren, warum ältere jQuery Scripte nicht mehr laufen.
Da muss man sie alten Funktionen hinausschmeißen und auf die neueren anwenden.

Ich würde das immer so programmieren, wie es jetzt aktuell ist.
Wenn die Plugins in paar Jahren geändert wird, kann man da sowieso nicht viel dran ändern
Hier sind alle meine Lösungen aus allen Foren. Ich helfe auch in Facebook-chat
Zitieren
#3
(02.09.2022, 15:59)Dvdscot schrieb: Hallo,

ich habe heute D3 kennen gelernt, denn ich muss bei einer Grafik zoomen können. Finde lauter Beispiele im Netz, sogar für verschiedene D3 Versionen. Je neuer desto "einfacher" soll es werden und ein Beispiel funktioniert nur mit V7, davor entweder nicht oder zeigt nicht mal ein Bild an. Man kann aber auch mit V3 und 4 schon zoomen.

Das Programm das ich vorgefunden habe ist auf V5 geschrieben. Soll ich also den Zoom so schreiben dass er für V5 funktioniert oder insgesamt auf V7 updaten? Könnte sein dass dann andere Funktionen nicht mehr funktionieren oder ist das abwärtskompatibel?

Hi Dvdscout,
kleinere Plugins und Frameworks in JavaScript sind häufig davon betroffen das diese nach einem Verionsupdate Funktionen verlieren. Häufig werden sich Lösungen eingesparrt oder es lohnt sich einfach nicht mehr bestimmte Funktionen weiter zu führen. Das führ dazu das es wenig bis gar keine Abwärtskompatibilität vorhanden ist.

Ich würde dir empfehlen sich gleich an der neuesten Version zu orientieren.

Viele Grüße

rzscout
"Gerne dürft ihr mir eine gute Bewertung da lassen aber auch gegenüber Kritik bin ich offen" Angel
Zitieren


[-]
Schnellantwort
Nachricht
Geben Sie hier Ihre Antwort zum Beitrag ein.

 

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste